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The optimizing program, called Board Stretcher™, resides on a computer in the plant production office.  

 

NOTE: In addition to the production office computer, Board Stretcher Software  

can also reside on the saw computer and multiple PCs with a shared database. 

 

The purpose of this program is to import the following file types:  

• Roof truss part listings (.OMN or .CUT) file from the truss design software  

• Wall panel file (.MIZ),  

• Universal part file (.XML) (Recommended) 

• Australia file (.MME) 

 

Once imported these parts are then placed onto stock boards using an optimizing process that is chosen by the user.  

 

The software will then output a board (.MDB, .MIZ or .XML) file for the Miserll, OmniMiser, MiniMiser or MatchPoint Blade 

to cut. 

 

The user of the Board Stretcher software is responsible for defining a library of material that lists all available stock that is 

available for the saw to select from. This list should contain stock that’s available in the bunk feeder and magazines as well as 

stock that is available for the operator to load manually.  

 

This list is called the Lumber Yard and it contains Grade, Size, and Length data about each type of lumber available as well 

as the Source – (manually loaded, magazine fed, or bunk fed) 

 

NOTE:  This information was written for Board Stretcher version 5.0 and may vary slightly from other versions 

Board Stretcher 
Overview 
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How It Works 

 

The heart of the Board Stretcher program is the ability to combine the Parts List and the Lumber List for the efficient use of 

material. Board Stretcher will then create a board listing with boards that contain all the parts for that job for every grade and 

size.  

 

The optimization algorithm is as follows: 

• The optimization process will sort all the parts from the imported selection into: Board Grade, Board Size. Part Lengths 

are sorted in descending order. 

 

• It selects the longest part first and the first length of board with the same grade and size and place the part.  

 

• It then takes two independent paths to placing additional parts on the board. 

o The first selects the part with the best matching angle to the preceding part. 

o The second selects the longest part that will fit on the remainder.  

 

• After part placement is completed using both of these methods, the board that has the least amount of waste is chosen, 

and the other is discarded.  

 

• This process is repeated for all board lengths within a grade and size to attempt placing the parts on. The placement 

methods are the same, but after the parts have been placed on each length, the board that has the least percentage of 

        scrap is chosen and the others discarded. 

 

• This process is repeated for additional boards until all parts are placed. 

Board Stretcher 
Overview (cont) 
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Information: 

• When changing units of measurement, the same unit must be chosen in the BLADE Saw software before optimizing the 

job. 

• Imperial measurements (English) are given using 3 pair of numbers. 12-06-08 means 12 feet, 6 inches, and 8/16 inches 

(12’ 6-1/2”). Metric measurements are given in whole millimeters (mm). 

• Lumber grade name format must be entered following guidelines agreed upon at your facility. It must EXACTLY match 

the design file’s grade name for the lumber, or the system will not recognize it as an existing lumber. 

• The WoodRunner ™ lumber retrieval system is now called Ranger RS™ 

 

The information here may help when determining length entered for stock lengths. 

This scenario is based on cutting (2) 8’ boards from a 16’ stock length. 

• Adding material to the Lumber Yard is generally entered by specified length not actual length. 

• Bundle material actual length is generally ¼” to ⅜" longer than specified length. 

• The Blade cannot cut (2) 8’ boards from a stock length of 16’ because the kerf is not accounted for. 

• Entering the 16’ length as 16-00-04 (actual measured length) allows the extra material for the kerf and (2) 8’ boards can 

now be cut from a stock length. 

 

Terminology: 

• Kerf - the nominal cut thickness removed by the saw blade. 

• Part - A piece of a board, cut to the exact size and shape required for the job 

• Board - A specific piece of lumber with specific dimensions required by the saw to cut out specific parts 

• Lumber A group of boards or a non-specific board; no consideration given to the final size or shape 

Board Stretcher 
Information and Terminology 
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This section will introduce the user to all drop-down menus. 

 

       

Board Stretcher Menus 
File 

Auto Process - Allows you to quickly import a 

job and have the program optimize it according 

to your present preferences and then sends the 

output to the saw in a directory that you have 

set. 

Completes the import, optimize, and export 

steps all with one click. (Also on the Task Bar as 

Auto) 

 

Import - Opens a file browse window for the 

user to import a file/files into the program. Hold 

the CTRL button on the keyboard to select more 

than one file which will combine the files. (Also 

on the Task Bar as Import) 

 

Optimize - Will place all of the parts from the 

file/files onto boards to give you the best 

optimization of your lumber. (Also on the Task 

Bar as Optimize) 

 

Stop - Once optimization has begun, it can be 

stopped using this menu choice. (Also on the 

Task Bar as Stop) 

 

Export -  This selection sends the optimized job 

to the saw. (Also on the Task Bar as Export) 

 

Clear - Removes the active job from “active” 

status. Clears all data in the primary tabs except 

the Optimizations tab. 

 

Exit – Closes the program 
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Board Stretcher Menus 
View 

Complete Log - This selection allows you to view 

all logged data. 

 

Import Log - This selection allows you to view 

any import-related errors or information. 

 

Run Log - This selection allows you to view any 

changes made to options and records entries 

when something has been completed such as 

import, optimize, or export. 

 

Error Log - This selection allows you to view any 

errors that happened during the optimization 

process. 
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Board Stretcher Menus 
Lumber and Print 

Lumber (Also on Task Bar) 

This is formatted differently than other entries and 

allows you to view and modify your Lumber Yard, 

or the lumber that you make available to the saw. 

Board Stretcher uses this information to optimize 

your lumber usage. 

 

When Lumber is clicked, either from the Lumber 

Menu or from the Task Bar, a second screen 

appears on top of the primary screen. 

 

Print Menu (Also on Task Bar) 

There are different reports included in Board 

Stretcher that can assist in managing lumber 

used. All three reports can be printed from the 

Print menu. Two of them can also be printed 

using the Print button on the Task Bar. 
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Grade Replacement - Changes lumber grades  

in the import file to a different grade, either for  

all lumber in a grade, or for specific widths in a 

grade. 

 

Lower Grade Fill - Place lower grade material 

onto higher grade material if there is room left  

on the end of a board. 

 

Add Part – Choose a generic part and customize 

it from scratch to add a part to the job that wasn’t 

in the job file. 

 

Edit Part – Change the design, quantity, grade, 

etc. of a part already in the job file. 

 

Backup – Upon clicking Backup, the config.mdb 

file will save to a user specified directory. 

 

Company – Allows you to fill in your company 

information so it can be used on reports 

 

Options – See the next step for details 

 

Admin - All of the standard configuration items an 

operator should ever need can be set in Admin. 

 

NOTE: Admin settings should not be changed 

without consulting with MiTek first. The correct 

setting were entered by a MiTek representative  

at installation. 

Board Stretcher Menus 
Tools 
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Machine Name – Choose the name the Board 

Stretcher application uses in log entries. 

 

Display and Input Units - Choose imperial or 

metric measuring units 

 

Square Cut – Set the angle for a square cut 

 

Kerf – Set the blade thickness 

 

Maximum Part Length – Set the maximum part 

length for a single part 

 

Importing Parts with End/Rip Bevels allowed – 

If checked Board Stretcher allows the importing of 

bevels without showing an error 

 

Remove End/Rip Bevels from Parts when 

Imported - If checked Board Stretcher will 

remove bevels on parts for saws not capable of 

processing bevels.  

Tools > Options 
General Tab 
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Lower Grade Fill – Allows the software to automatically 

take parts calling for lower grade material and place it on a 

higher grade material if there is room on the end of a 

board.. 

 

Replace Grades - Allows you to replace lumber grades in 

the import file to a different grade, either for all lumber in a 

grade, or for specific widths in a grade.  

 

Optimization Basis - Allows you to select either cost or 

waste as the basis for the optimization. If waste is 

selected, it will optimize to give the minimum waste. If cost 

is selected, it will optimize to give the minimum cost, 

based on costs entered into the Lumber Yard data. 

 

Batch - It allows the output of the saw to group parts 

together within a job to simplify sorting at the saw. The 

downside, however, is that this will negatively affect the 

optimization. 

 

Create Batch Data - Allows the operator to create multiple 

batches for files that do not already contain batches.  

Setup for batching criteria are located on the Batching tab. 

 

Use Lumber Penalties - Enables/disables whether or not 

the lumber penalties are used for the optimization process 

(based on either cost or waste). If this selection is enabled, 

it will display the default lumber penalties that will be 

applied when adding new boards to the Lumber Yard. 

Tools > Options 
Optimization Tab 
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Import File Type – Choose the type of file format that you will be 

using when importing files from your design program to Board 

Stretcher.  

 

Export File Type - Choose what type of file format you will be 

sending to the saw from the Board Stretcher program. The Miser 

II saw and MatchPoint Blade will only accept .xml files. 

 

Output Board Sort Order - Choose the output of the boards. This 

option controls the order of the optimized boards.  

 

 

NOTE: This does not affect how the boards are 

optimization, only the order the saw requires boards. 

 

 

 

NOTE: Output Board Sort Order  

(A=Ascending D=Descending) 

 
 

Tools > Options 
Import/Export Tab 
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Export Folder – The path where the optimized job 

file will be saved at all times. This is the folder from 

which the saw will retrieve jobs. 

 

Manual Import Folder - The default path that will be 

selected when importing the file without optimization 

 

Auto Import Folder - The path that the software 

watches for files to import, optimize, and export 

automatically. This folder must be kept empty, as 

every file that exists in the directory will be read in  

as a job file. 

 

Auto Valid Transfer Folder - The path where the un-

optimized job files are moved when the Auto Import 

(import, optimize, and export) has completed 

successfully. This is NOT where the optimized files 

are moved. 

 

Auto Invalid Transfer Folder - The path where the 

un-optimized job files are moved when the Auto 

Import (import, optimize, and export) was 

unsuccessful. This is typically caused by lumber 

required not matching the Lumber Yard, or parts 

being too short or long. 

Tools > Options 
Directories 
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Backup Folder – Where the backup files are 

stored. 

 

 

 

 

 

 

Square Cut Only - This option will be set if your 

saw only has the ability to cut square angles or 

force all cuts square 

 

3x Search Pattern - If you have the ability to cut 

3x material on your saw, you will enter a text string 

that occurs in the board grade which identifies the 

board as a 3x (instead of the default 2x). 

 

Add Part Print - Adds part description to what is 

already being printed on the board. 

 

Flip Print - Adjusts the location of printing on the 

top and bottom board so the printing can be easily 

seen. Available only for .MIZ files. 

 

Regex - An advanced method of batching. Contact 

MiTek if there is a need to use the Regex feature. 

Tools > Options 
Backup and Wall Panel 
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Auto Print – As soon as the job is exported the 

pick list or board list for the job will be printed. 

 

Print To - You can either print to your default 

printer or to a pdf file. 

 

Default Printer – Select the default printer 

 

PDF Folder - This is the path that pdf documents 

are created in. 

 

Errors - For Auto Process jobs, errors for each 

job will print to the designated printer as the job 

attempts to run. 

Tools > Options 
Reports 
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Printers – Select the applicable checkboxes for the current 

board printing system. 

Truss Print Justify - Select Leading Edge, Trailing Edge 

or Center to determine where the text will print on each part. 

Trailing Edge is most commonly used. This is the location of 

the printed info which is closest to the stacker. 

 

Print Selection –  

• Default prints the following information: Name, 

description, and quantity of like parts.  

• Custom must be selected to print anything other than 

the default information. 

 

Custom Print Fields –  

• Column - The Column is the number of digits, from the 

left, of a given field. 

• Length - The Length is how many digits including and 

following the column selected in a given field. 

o For example, if Description is chosen, and the 

Description is '1135-W2-787', the Starting Column 

is set to 6, and the Length is set to 2, 'W2' will be 

printed. 

• Arrows – Move a selected field up and down the list. 

 

• Add – Click this button to add a blank field for a new 

entry. 

 

• Remove – Remove a selected field. 

Tools > Options 
Print 
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Custom Print Fields – Specifies which information will print on  

boards and the number of characters being printed. 

 

Field – On Parts > Part Data Tabs. 

 

 

 

 

 

 

Column –  The character where the print information begins. In      

                  this example, the 4th character from the left. 

 

 

Length – The number of characters to be printed. In this example, 4. 

 

Based on the Custom Print Fields for JobName, 2748 would print on the board. Also, following the  

same parameters, the information for Assembly, Description and Quantity would be included 

 

 

 

NOTE: When setting up a new printer on a MatchPoint™ BLADE,  

refer to the troubleshooting documentation available online at  

www.MiTek-US.com for the correct settings 

 

 

 

 

 

Tools > Options 

Custom Print Fields 

 

http://www.mitek-us.com/
http://www.mitek-us.com/
http://www.mitek-us.com/
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Print Which End is UP 

 

Board Stretcher software has a new option to help 

distinguish the direction a part should point during 

assembly of a truss.  

 

If the software has been updated to version 5.0.3.0 or 

later, the saw’s printer can add an arrow to the part.  

 

The arrow always points to the end of the part that 

should be higher (closer to the top of the truss) than the 

other end. If the part is perfectly horizontal, no arrow 

prints.  

 

This feature works on any MiTek linear saw using Board 

Stretcher software.  

 

From Tools > Options, select PartHighSide in the 

Custom Print Fields. 

 

Will only work on 3 dimensional file types. XML output 

format required (MDB for Miser I) 

Tools > Options 
Custom Print Fields 

NOTE: Custom fields print in the order they are listed.  

This can be changed using the up/down arrows.. 
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• OverAllLengthFraction - the standard way to show 

measurements is ft-in-sixteenths (8-6-3 displays for 8’ 

6-3/16”) Choosing this field will make the measurement 

print as 8’ 6-3/16”, although I’m not sure of the exact 

use of symbols like the dash and ‘ and “ that I used 

here. 

 

• Side - Prints an L or R to indicate left side or right side 

of the truss so it can be sorted on separate carts or 

piles. Often used for long trusses. This field divides 

divide truss at the peak to determine L and R. 

 

• AOSide - Same as Side, but truss is divided at the 

center of its span to determine L and R. 

 

• Text - allows you to add any text you want to the print. 

Select the field Text and type a short text string into the 

Text column. That text will print directly before the next 

custom field. You could add “qty” tp print directly before 

the numerical quantity. Or you could print your 

company name at the end of every truss. 

 

• PartHighSide - Prints an arrow (< or >) pointing toward 

the top of the truss; the end of the part that is higher 

when assembled. If the part is perfectly horizontal in 

the truss, no arrow prints. At this time, this feature is 

only available for the BLADE saw. 

Tools > Options 
Custom Print Fields (cont) 
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Batching Data –  

 

• Column - The Column specifies the position of the 

first digit in a given field. 

 

• Length - The Length specifies how many digits 

following the column (and including the column 

itself) are selected in a given field. 

 

• Arrows – Move a selected field up and down the 

list. 

 

• Add – Click this button to add a blank field for a 

new entry. 

 

• Remove – Remove a selected field. 
 

Tools > Options 
Batching 
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Batching information 

• Has a significant negative impact on efficiency 

• Cuts only in a specific order of information entered in the Batching Data section 

• In trusses the Field column will be set to Assembly or Truss. 

• In trusses, cuts all of the parts for one truss then moves to the next truss. 

• Arrow buttons move the highlighted item up or down 

• Clicking the Add button adds an additional row. 

• Clicking the Remove button removes the highlighted row. 

• Remainder board, after one truss, will not be used by next truss but rather ejected as scrap or cut into applicable 

remainders. 

 

 

Tools > Options 
Batching (cont) 
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Saws: 

 

• A list of available saws 

 

 

Input Box: 

 

• The listed saw can be added, removed or renamed. 

 

 

Tools > Options 
Saw 
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Board Stretcher Menus (cont) 
About and Help 

About – Displays version number and Copyright 

information 

 

 

 

 

 

Help – Access to Help Files and Technical Support for 

contact and reporting problems 
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Board Stretcher Menus 
Task Bar 

Auto – Allows you to quickly import a job and have the program optimize it according to your present preferences . Then sends the 

output to the saw in a directory that you have set. Completes the import, optimize, and export steps all with one click. Also found under 

File > Auto Process 

 

Import – Opens a file browse window for the user to import a file into the program. Hold the CTRL button on the keyboard to select 

more than one file. Also found under File > Import. Multiple selections will be combined. 

 

Optimize - Will place all of the parts from the current import selection. onto  boards to give you the best optimization of your lumber. 

Also found under File > Optimize 

 

Stop - Once optimization has begun, it can be stopped using this icon. Becomes active after the Optimization button has been clicked. 

Also found under File > Stop 

 

Export - This selection sends the optimized job to the saw. Also found under File > Export 

 

Lumber - This Is the lumber that you make available to the saw. Board Stretcher uses this information to optimize your lumber usage. 

When Lumber is clicked a second screen appears on top of the primary screen. May also accessed from the Lumber tab 

 

Print - There are different reports included in Board Stretcher that can assist in managing lumber used. All three reports can be printed 

from the Print menu. Two of them can also be printed using the Print button on the Task Bar. May also accessed from the Print tab 



  

              

MiTek University 

Board Stretcher 

Last update 7/14/2017 

Page 25 

Board Stretcher Menus 
Status Bar 

Board Count – Displays the number of boards used in optimization. 

 

Part Count - Displays the number of parts that are in the imported selection that have been placed on boards. 

 

Current Job Status (green) - Displays the current state of the optimization process.  

Status options include: 

• Imported 

• Imported (with errors) 

• Optimizing 

• Optimized 

• Exported 

• Error 

 

Board Status - Displays the status of the optimized boards. It can either be OK, Warning, or Error. 

 

Part Status - Displays the status of the imported parts. It can either be OK, Warning, or Error. 
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Board Stretcher Menus 
Saw Selection 

Board Stretcher allows you to have multiple configurations saved.  Here you select the one you are using.   

 

These are referred to as “saw” but the difference can be as minor as a different lumber selection in the lumber yard or a print setting for 

an alternate scenario based on needs.   

 

This selection does not impact auto mode. Auto uses its individually configured auto import folders and does not need the SAW to be 

selected to operate on its respective configuration.  

 

 

NOTE: The only two times you need to have the correct SAW selected  

is if you are manually importing a job to optimize or if you are making a  

configuration setting change that is SAW specific. 
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Board Stretcher Menus 
Primary and Secondary Tabs 

The primary tabs near the top of the Main Screen provide different options 

 

The secondary tabs change, depending on which primary tab is selected. 

 

Parts - Displays the parts in the active import selection (by list and by graphic). 

 

Boards - Displays type, quantity, and waste information for the active import selection It includes lumber needed from inventory as well as 

each board. Data is displayed in a list and graphically 

 

Assemblies - Graphically displays the assembled truss and each board required IF the imported file contains truss or panel information. If 

not, this tab remains blank 

 

Optimizations - Lists each time the active import selection has been optimized, allowing a comparison to choose the scenario with the 

least waste. 
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To manually Import a job: 

 

1. From the Task Bar, click Import. 

 

The user can import any of the following file types 

• .OMN or .CUT – generated by the truss design software 

• .MIZ - generated by the wall panel design software 

• .MME – Used in Australia 

• .XML - could contain wall or truss information 

 

2. Select the next job from the list 

 

 

 

NOTE: If any problems occur with the import file,  

the optimizing software will automatically try to 

correct the problem as well as notify the user of  

the problem. 

 

 

When importing a job with boards requested from your Lumber  

Yard that have not been added before, this message will appear. 

 

Click Yes to continue. 

   

 

 

Board Stretcher Operation 
Importing a Job - Manually 

Task Bar 

Job List 

NOTE: Cutlists that can be imported into Board  

Stretcher are CyberSort, MVP and ShopNet  
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To create the Lumber Yard for the job: 

 

3. From the Task Bar, click Lumber. 

 

If the Board Stretcher program determines that any grades and dimensions of lumber in the job file are not available in 

the current Lumber Yard, it will allow replacement grades to be selected OR new lumber grades and dimensions to be 

added to the Lumber Yard.  

 

Materials listed under the Lumber in  

Yard panel are recognized material.  

 

 

 

 

 

 

 

 

 

Materials highlighted in red, under  

the Current Job Inventory panel,  

are new materials not recognized. 

 

 

Board Stretcher Operation 
Importing a Job - Manually (cont) 

Task Bar 
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Source - Bunk and Manual notifies the picker as to where the required material is located. 

These are more of an internal indicator and are not required by the Blade or Miser.  

 

 

To add material to the Lumber Yard, highlight an item in red. 

 

 

 

 

 

 

 

After completing all fields needed click the Add  

button to add the grade to the Lumber Yard. 

  

 

Board Stretcher Operation 
Importing a Job - Manually (cont) 
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All information entered in the Lumber Yard is very specific. 

 

NOTE: If entries vary, even just in terms of punctuation or capitalization, Board Stretcher views the entries as separate entries.. 

 

There is a function, Grade Replacement, that allows for slight variations on input: 

 

 

 

 

 

 

 

           NOTE: 

           The entry shown above will remove Grade and replace it with New Grade. SPF 

           No.2 will never exist in the file as it will be overwritten by No.2 SPF 

               - To have this affect all widths leave the Width column empty. 

               - To only affect specific widths, such as 2x6, enter a 6 in the Width column. 

 

 

 

 

Another example using Grade Replacement.  

• With Grade Replacement, Board Stretcher would recognize that a 2x4 and a 2X4 are the same  

 

Board Stretcher Operation 
Adding Material 
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Click a material, in red, in the Current Job Inventory panel and that material will highlight in blue. This material can be added 

to, or replaced by, material in the lumber yard. 

 

 

 

 

 

 

 

Suggested replacement lumber for the new material will be highlighted in green in the Lumber in Yard panel. 

 

 

 

 

 

 

 

 

 

 

 

 

 

To use a substitution material, simply double click one of the materials highlighted in green. 

 

 

Board Stretcher Operation 
Adding Material (cont) 
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To optimize the parts onto the boards: 

 

4. From the Task Bar, click Optimize. 

 

The program then begins the process of 

placing the parts onto boards.  

 

Different optimizing processes and options 

are available to the user to achieve the 

results desired.  

 

The user also has the capability to re-

optimize the same job several times using 

different options to achieve the best results. 

 

 

NOTE: re-importing previously exported files, 

optimized files, will result in duplicate print. 

Board Stretcher Operation 
Importing a Job - Manually (cont) 

Task Bar 
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To send the board list to the saw: 

 

5. From the Task Bar, click Export. 

 

When the user is satisfied with the 

optimization results, the job can then be sent 

via network connection directly to the saw.  

 

The job is then ready to be cut.  

 

After the current job is sent to the saw, the 

optimization program is ready to import and 

optimize the next job. 

Board Stretcher Operation 
Importing a Job - Manually (cont) 

Task Bar 
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To automatically Import a job: 

 

1. From the Task Bar, click Auto. 

Board Stretcher Operation 
Importing a Job - Automatically  

Task Bar 
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• Before Board Stretcher can use a type of lumber, it must be added to the Lumber Yard. Ideally, when Board Stretcher is 

installed, all lumber stocked at your facility should be added to the Lumber Yard. Then, future jobs only need to add odd 

or new lumber, and the daily optimizing tasks flow more smoothly. Adding lumber is a simple procedure, no matter if it 

occurs before the job is imported or after. 

 

 

NOTE:  Populating the Lumber Yard should be accomplished by opening job files so the grade strings are automatically 

populated.  It is not recommended to type in the grade strings as they must be an exact match to the job files. 

 

 

• When Lumber is clicked, either from the Lumber Menu or from the Task Bar, a second screen appears on top of the 

primary screen. 

 

• This selection allows you to view and modify your Lumber Yard, or the lumber that you make available to the saw. Board 

Stretcher uses this information to optimize your lumber usage. 

 

 

 

 

The Lumber Yard 
Information 
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The two methods for accessing the Lumber Yard 

are: 

 

1. Click the Lumber button on the Task Bar 

from the main screen. 

 

2. Click the Lumber menu from the main 

screen. 

 

 

Click YES to the message that could appear when 

importing a new job: 

The Lumber Yard 
Entering the Lumber Yard 
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1. Click one of the missing lumber types in the left 

column (Current Job Inventory). Missing lumber 

is highlighted in red. 

 

• The Grade field automatically populates 

with the lumber selected in the left column. 

 

• Existing lumber that is a valid substitution    

      gets highlighted green in the right column   

      (Lumber in Yard). 

The Lumber Yard 
Add Lumber and Reassign Boards in Active Jobs 

NOTE: Before replacing material grades at this  

screen, ensure the lumber is physically stocked  

in inventory, or will be when the sawyer is ready  

to cut this job.  This information is not tied in with  

the user’s physical inventory software 
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2. Either assign a substitution or add the missing lumber. Both options are described here. 

 

a) To assign a substitution: 

1) Double-click a green lumber type in the right column. 

2) Click Yes when the system asks you to verify your choice. 

 

b) To add lumber to the Lumber Yard from this screen: 

1) Click the lumber in the left column that is missing so it populates the fields in the middle column. 

2) Adjust the Size, Length, Source, Cost, and Penalty fields if necessary. 

3) Click the Add button. 

The Lumber Yard 
Add Lumber and Reassign Boards in Active Jobs (cont) 
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To add lumber to the Lumber Yard before a job is imported: 

1. Enter the Lumber Yard (use instructions described in the Enter  

      Lumber Yard section covered previously) 

2. In the middle column in the Add Lumber section, type the grade  

      name, NOT RECOMMENDED, into the Grade field. 

 

NOTE: Type the Grade following format guidelines  

agreed upon at your facility. It must EXACTLY match  

the design file’s grade name for the lumber, or the  

system will not recognize it as an existing lumber. 

 

 

3. Fill in the Size from the drop-down menu (2x3, 2x4, etc.) 

4. Fill in the Length from the drop-down menu (12-6-0 equals 12 ft. 6 in. and no 

sixteenths of an inch), 

5. Fill in the Source from the drop-down menu. 

6. The Cost field should be filled in only if cost will be considered over material usage 

when determining acceptable waste. 

 

NOTE: Penalty fields will be explained in another step. 

 

7. Click the Add button. 

The Lumber Yard 
Add Lumber without an Active Job 

NOTE:  Populating the Lumber Yard should be accomplished  

by opening job files so the grade strings are automatically 

populated. It is not recommend to type in the grade strings. 
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Reasons to remove material from the Lumber Yard: 

• You no longer inventory a certain lumber 

• Cleaning out your Board Stretcher Lumber Yard 

 

To permanently remove material from the Lumber Yard: 

• Under Lumber Yard, select a lumber type in the right panel and click the 

Remove Selected Items button. 

The Lumber Yard 
Remove Material from the Lumber Yard 
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The user can prevent a type of lumber from being used without removing it from the 

Lumber Yard. 

 

• Example: You ran out of 16-ft lumber, and it won’t be here for another 

week.  

 

To prevent lumber usage: 

• From the center section of the Lumber Yard (Add Lumber), remove it from 

active duty by unchecking its Active checkbox. 

• When the lumber becomes available , just enter the Lumber Yard, select 

that lumber, and check the checkbox again. 

The Lumber Yard 
Temporarily Prevent Material Use 
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A Penalty is a feature that allows the user to discourage Board Stretcher from using 

a certain type of lumber, while still allowing it when necessary. The higher the 

penalty, the stronger the discouragement for using. 

 

There are different types of penalties: 

1. Cost Penalties - make the software think the lumber costs more than it really 

does. 

a) Default cost penalty 

b) Optimization cost penalty 

 

2. Length Penalties - make the software think there is more waste on a type of 

lumber than there really is. 

a) Default length penalty 

b) Optimization length penalty 

 

 

NOTE: Default penalties are what will default when adding new lumber and are 

based on what the source is. Whatever penalty is shown in the Lumber Yard on  

the right side will be the penalty used. 

The Lumber Yard 
Penalty Fields 
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When lumber is first added to the Lumber Yard any penalty added will be referred to as the default penalty. 

 

• Example 1 - You started working with a new client, and are getting more trusses that would benefit from 20-ft lumber, but 

it is very expensive to buy. You want to use this lumber only when it’s absolutely necessary. So, when you add it to the 

Lumber Yard you placed a 2-ft length penalty, using the Add Lumber section. 

 

 

When a penalty is assigned because a change in inventory or policy requires a short-term change in lumber usage. Usually a 

length penalty in both of these cases is two feet less than the length of the board. 

 

• Example 2 - You’re running low on 16-ft lumber of a certain grade, and your supplier can’t get you more for several 

weeks. You typically use a lot of 16-ft lumber because it optimizes well, but now, you want to use it only when absolutely 

necessary. So, enter the Lumber Yard and add a length penalty at the bottom of the middle column. 

The Lumber Yard 
Length Penalty Examples 
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Penalties - how much of the total length, or additional cost per board, is to be considered waste or expense in the Board 

Stretcher algorithm prior to it calculating waste/cost to determine efficient lumber usage.  

 

NOTE: Penalties do not have a direct effect because the  

software uses many inputs to optimize board outputs. 

 

 

NOTE: Penalties can be set up before or after material is added 

 

When considering Cost and Length penalties, it is recommended to use Length  

and must be optimized by waste 

• Length Penalty  

o Once the length penalty behavior is set, material price does not affect the length penalty. The only 

determination is whether the board is available or not. 

• Cost Penalty 

o Cost is an advanced form of penalties and does not follow any database currently in use.  

o Creates a second costing location that must be maintained.  

o With a lumber cost increase the cost penalty dynamic changes. Cost penalties must be updated manually. 

o Using the same lumber price increase for the cost penalty changes the dynamic of the cost penalty.  

o Material price increase and cost penalty are not proportional. 

 

 

NOTE: There are many settings available in penalty options to create certain behaviors for lumber use but there are  

almost no absolutes. What happens with settings in penalties is a persuasion to the algorithm that decides what is  

used but it does not dictate what you can or cannot do. 

 

 

The Lumber Yard 
Penalty Information 
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NOTE: This example uses an empty Lumber Yard 

 

 

A job being imported contains the following 2 materials. 

 

 

 

 

 

These 2 materials are stocked in 16’ and 20’ each and are added to the Lumber Yard. 

 

 

 

 

 

 

 

 

All Penalties remain off at this time. 

 

The Lumber Yard 
Penalty Example 
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After clicking Optimize, below is the list of material under the Boards / Board Data tab 

 

 

The Lumber Yard 
Penalty Example (cont) 
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Under the Boards / Lumber Data tab is the pick list for material. 

 

 

 

 

 

 

 

 

For this example, it was decided that 20’ material is not to be used, due to cost, and a length penalty will be assigned. 

 

NOTE: Longer material increases board efficiency but is less cost effective.  

 

 

To add a penalty  

• Click the Lumber button to return to your lumber yard 

• Highlight the 20’  2x4 SPF No.2 material in the lumber yard 

• Under Length Penalty enter 4’ (the length penalty entered  

        tells the program to consider the penalty as waste)  

 

 

The Lumber Yard 
Penalty Example (cont) 
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Once the length penalty has been added click the Optimize button again to see results. 

 

 

 

 

 

 

 

 

Before length penalty 

 

 

 

 

 

 

 

 

After length penalty added and re-optimized – notice the drop in TotalBoardEfficiency 

The Lumber Yard 
Penalty Example (cont) 
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Additional persuasion factors, found in Tools > Admin > Edit Configuration, can be added with settings for: 

 

• Optimizes Longest Boards – will use the longest boards available. This influences the algorithm to ignore penalties.. 

 

• Optimize for Saw Performance – the saw receives a bonus percentage in terms of how much lumber is being saved 

vs how much is being used for nesting cuts. If a board has an angle cut that matches another angle cut the program 

will re-orient one board and nest the cuts. The saw receives a 10% efficiency bonus when this happens. 

 

The Lumber Yard 
Penalty Additional Information 
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When the Parts Tab is selected in the Primary Tabs  

section, the Secondary Tabs reflect the selection. 

 

 

 

In the Parts Data window, the data is populated by the design file. 

• Group - the stack on the truck if the design file specifies. 

• Assembly - the truss or wall panel. 

• Description - the individual part descriptions. 

Viewing Data 
Parts 

Primary Tabs 

Secondary Tabs 
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Part Error - If any of the parts contain an error they will be listed  

under the Part Errors tab.  

• The ID, Job, Description are the same as the Part Data tab.   

• Level indicates Warn or Err.   

• Error Msg displays the error message.   

o If the Level = Warn the part will still be included in the optimization,  

o if the Level = Err the part will not be included in the optimization.. 

Viewing Data 
Parts (cont) Primary Tabs 

Secondary Tabs 

Part Graphics –  

• Double clicking will flip the parts over.  

• Left clicking on a part will select the part,  

• Once selected, right clicking on the part will show a menu with the following selections: 

o View Part shows the part in the 3D viewer. 

o Edit Part shows the key-in interface populated with the part's information to allow for editing the 

 

 

NOTE: To right click on a touch screen, touch and hold  

View Part 

Edit Part 
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When the Boards Tab is selected, in the Primary Tabs  

section, the Secondary Tabs reflect the selection. 

 

 

 

In the Lumber Data window, the following information is available for the job: 

• Length – material length used 

• Source – how the material is entering the saw 

• Quantity – total number of this material needed 

• Total Board Ln. – the total board footage of all pieces for this length 

• Length Eff. - the efficiency percentage of the pieces cut from the selected board length 

• Total Waste Length – the amount of waste after all pieces are cut from a quantity of boards 

Viewing Data 
Boards 

Primary Tabs 

Secondary Tabs 
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When the Boards Tab is selected, in the Primary Tabs  

section, the Secondary Tabs reflect the selection. 

 

 

 

 

In the Board Data window, the data is populated by the design file per board. 

• Source – how the material is entering the saw 

• Waste – the amount of waste after the pieces are cut 

• Length Eff. - the efficiency percentage of the pieces cut from the selected board 

length. Does not reflect remainder usage at the saw itself. 

Viewing Data 
Boards (cont) 

Primary Tabs 

Secondary Tabs 
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Board Errors - If any of the boards contain an error they  

will be listed under the Board Errors tab.   

• The ID, Grade, Size, Length are the same as the  

    Board Data tab.   

• Level indicates “Warn” or “Err”   

• Error Msg displays the error message.   

o If the Level = Warn the board will still be included in the optimization,  

o If the Level = Err the board will not be included in the optimization. 

 

Board Graphics –  

• Double clicking will flip the boards over.   

• Left clicking on a individual part of a board will show the 3D viewer for the part. 

 

 

 

 

 

 

 

 

NOTE: The red line indicates a board that only has short parts on  

it. When this happens, Board Stretcher has to slide everything to  

the front. The front of the last part has to be past that line so the  

gripper can position for it. 

Viewing Data 
Boards (cont) 

Primary Tabs Secondary Tabs 
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Assembly Graphics - displays the image of the 

fabricated component the cut pieces will produce. 

Viewing Data 
Assemblies 

Primary Tabs 

Secondary Tabs 



  

              

MiTek University 

Board Stretcher 

Last update 7/14/2017 

Page 57 

Optimizations - The Optimizations tab allows you to compare different optimizations of the same file. Settings can be 

changed and the file re-optimized. The best optimizations can be found using this method. 

 

Definitions:   

• Length Efficiency = Overall length of all parts/length of all boards x 100 

• Volume Efficiency = Volume (board feet) of parts/volume of boards x 100 

• Board Feet of boards used 

• Cost of the boards if optimizing by cost 

• Quantity of parts which share one common angle with another adjacent part on the board.  

• Quantity of parts which share two or more common angles with another adjacent part on the board.  

 

• When adjacent parts share common angles the saw will stroke into the wood fewer times increasing the production 

rate.   

o Saw Strokes Saved indicates how many strokes are saved. 

Viewing Data 
Optimizations 

Primary Tabs 
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Remainders - Remainders are commonly used parts cut from the natural waste inside a job. They can be set aside and 

used in future jobs as needed. Remainders are set in the saw software, if your saw has that capability. 

 

If remainders are set up efficiently the Blade Report will show better results than Board Stretcher 

 

When Batching is used for truss-by-truss or wall-by-wall, setting up more detailed remainders will use more cutoff 

material. This will improve efficiency on the Blade. 

 

Remainders may be cut at the Blade or at another saw. Cutting many short boards at the Blade will increase cut time. 

 

Blade efficiencies are higher with longer boards and lower with shorter boards due to the load time of material. 

 

NOTE: Board Stretcher does not know what the saw does with remainders. 

 

 

Remainders 
 




